Temporary internal network disruption

Incident Report for Findity

Resolved

The issue has now been resolved. All components are stable and operational.
Posted Jun 11, 2026 - 12:55 CEST

Investigating

We have experienced a temporary internal network disruption. No login was possible during the event. We are currently investigating the issue and will post updates as we learn more.
Posted Jun 11, 2026 - 11:58 CEST
This incident affected: Expense Management Platform (Web and mobile services).