Issues calling Findity

Incident Report for Findity

Resolved

This incident has been resolved.
Posted Jul 04, 2024 - 11:05 CEST

Investigating

Currently, there seem to be issues contacting Findity by phone. We are investigating this together with our provider Telenor.

In the meantime, please contact us via support@findity.com.

This status will be updated once more information is available.
Posted Jul 04, 2024 - 10:42 CEST
This incident affected: Expense Management Platform (Support services).