Phone line currently down

Incident Report for Findity

Resolved

This incident has been resolved.
Posted Mar 22, 2024 - 13:11 CET

Update

Telenor sees some improvements but will continue to investigate this, therefore we cannot guarantee that we will be available by phone until this has been solved. Latest updates from Telenor is that this will be solved by 13:30 am CET.
Posted Mar 22, 2024 - 11:19 CET

Update

Latest news from Telenor is that they are continuing to investigate this. They estimate the problem to be solved around 11 am CET.

Some more information directly from Telenor (in Swedish): https://www.telenor.se/support/driftinformation/driftstorningar-pa-mobilnatet/
Posted Mar 22, 2024 - 10:25 CET

Monitoring

We are currently monitoring Telenors progress.
Posted Mar 22, 2024 - 09:35 CET

Investigating

Currently, our support phone line provider, Telenor, is experiencing disruptions. They are actively investigating this matter, and we will provide further updates as soon as additional information becomes available.

The last update from Telenor is that they estimate the problem will be solved att 10:14 CET today.
Posted Mar 22, 2024 - 09:34 CET
This incident affected: Expense Management Platform (Support services).