Access issue

Incident Report for Findity

Resolved

This incident has been resolved.
Posted Aug 18, 2025 - 10:10 CEST

Update

We are continuing to investigate this issue.
Posted Aug 18, 2025 - 08:00 CEST

Investigating

At the moment we are experiencing issues with access to the service.
We are currently working to resolve this.
Posted Aug 18, 2025 - 07:01 CEST
This incident affected: Expense Management Platform (Web and mobile services, Support services).