Delay in cleared and invoiced transactions - OpenCard

Incident Report for Findity

Resolved

This incident has been resolved.
Posted Mar 25, 2024 - 07:30 CET

Monitoring

Due to an issue at the issuer there is a delay in the delivery of cleared and invoiced transactions from OpenCard. We will update this once the system is up running as normal again.
Posted Mar 21, 2024 - 15:01 CET
This incident affected: Expense Management Platform (Web and mobile services).