Network Equipment Issues - Ongoing Maintenance

Incident Report for Findity

Resolved

The issue was resolved around 16:00 CET yesterday.
Posted Oct 24, 2024 - 07:25 CEST

Update

Work is still ongoing and the new estimated time until this is resolved is 16:00 CET. After that things are expected to go back to normal.
Posted Oct 23, 2024 - 14:41 CEST

Identified

We are currently experiencing issues with our network equipment, which may cause minor disruptions for some users. Our team is actively working to resolve the problem, and we expect to have everything back to normal by 14:30 CET.
Posted Oct 23, 2024 - 09:47 CEST
This incident affected: Expense Management Platform (Web and mobile services).