Due to an issue at the Nordea there is a delay in the delivery of cleared and invoiced transactions.
Incident Report for Findity
Resolved
This incident has been resolved.
Posted Nov 11, 2024 - 06:53 CET
Monitoring
We will update once the system is up and running as normal again.
Posted Nov 05, 2024 - 09:16 CET
This incident affected: Expense Management Platform (Web and mobile services).