Platform Access Disruption

Incident Report for Findity

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 16:37 CEST

Investigating

Some users may be unable to access our platform due to network-related issues. Our team is actively working on a solution, and we expect services to be restored soon. Thank you for your patience!
Posted Apr 01, 2025 - 15:27 CEST
This incident affected: Expense Management Platform (Web and mobile services).