Problems connecting to the login page
Incident Report for Findity
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 10:07 CEST
Investigating
Users are currently experiencing problems connecting to the login page, which users are affected depends on which internet provider they use, affected internet providers are Telia and Bahnhof etc.
Posted Apr 10, 2024 - 07:43 CEST
This incident affected: Expense Management Platform (Web and mobile services, Support services).