Slow system

Incident Report for Findity

Resolved

This incident has been resolved.
Posted Nov 09, 2023 - 14:30 CET

Update

We are continuing to investigate this issue.
Posted Nov 09, 2023 - 13:08 CET

Investigating

Some users might be experiencing the system as slow, we are currently looking into this and the probable cause is some backlog work.

The system is still functional but might be experienced as slow as stated above. The status will be updated once we know more.
Posted Nov 09, 2023 - 09:01 CET
This incident affected: Expense Management Platform (Web and mobile services).