Mastercard connection issue

Incident Report for Findity

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 16:03 CEST

Monitoring

We are currently experiencing an issue with connecting Mastercards to the platform. We are monitoring the situation closely and will update this incident as soon as the issue is resolved.
Posted Sep 25, 2025 - 14:52 CEST
This incident affected: Expense Management Platform (Web and mobile services).